Watch2Gether Forcing Closed Captions on Youtube (Chrome)


#1

I seem to be having an issue where any time I load a video from Youtube with closed captions available into Watch2Gether, it forces the closed captions on regardless of my Youtube setting. What’s interesting is that it seems to be modifying the Youtube setting/cookie specifically, as if I reload that video in a new window from Youtube directly, it now has its CC activated.

|||||
My testing process:
1.) Load video with CC on Youtube. Ensure that CC is disabled.
2.) Refresh video on Youtube. CC is still disabled.
3.) Load video in different window in Watch2Gether. CCs are activated.
4.) Refresh first window with video on Youtube. CCs are activated there as well.
|||||

I can repeat this process reliably without fail with any number of different videos with CC available, including ones where the captions were added by fans (which nearly eliminates the possibility for a “yt:cc=on” tag on the video). I’ve cleaned out all cookies related to Google, Youtube, and Watch2Gether without the issue being resolved, as well as clearing my cache. I’ve also double checked that I don’t have Youtube set to automatically display CCs in its own settings. I’ve disabled all addons. As far as I can tell all signs seem to be pointing to Watch2Gether itself being responsible, unless Youtube has done something on their end that users don’t have access to?

(EDIT)
After further testing I can confirm that my Watch2Gether seems to be forcing CC on even with videos that don’t have them. If I play ANY video in Watch2Gether and then reload a video on Youtube that has CC, the captions have been turned back on.

(EDIT 2) And I just realized I didn’t mention this, it’s also forcing the CC on in Watch2Gether itself in the process, with no way to turn them off.


#2

Thanks a lot for your detailed feedback. There has been indeed an update on Youtube’s side. The related code in Watch2Gether has not been changed in the last weeks. At this point i can not really tell if this is a bug or a feature. As a workaround i have enabled the native controls of the Youtube player in Watch2Gether, which allows you to at least disable the subtitles…


#3

Much appreciated! I guess it isn’t needed now, but I did test this on Firefox, Internet Explorer, and Edge over the past couple of days all with the same result, so definitely not a browser-specific conflict either.

Thank you for the response, and the service! Watch2Gether is by far the best video syncing option I’ve found. Hopefully this issue will just work itself out on their end!