Videos lagging in full screen mode


For about a week now, video has been stuttering when video is in full screen. It doesn’t have any issues when I’m in normal mode, and it seems to be affecting videos regardless of the resolution settings. It’s affecting videos from every platform, and seems to happen on both Chrome and Edge.



Hi and thanks for your feedback. When you go to YouTube directly with the same browser, does the full screen playback run smoothly there? Any other changes to your system recently? (Such as graphics driver update…)


Hi there, I’m not a PLUS member but I have been using this service for a couple years now. I’ve had the same issues the OP mentioned. But yeah, I can go to YouTube and the playback is fine. Any other questions? Any recommendations?


Thanks a lot for your input. Can you tell me which browser / version you are using on which OS?


I’m using Chrome Version 57.0.2987.133 which should be the latest one if I’m not mistaken. Yours isn’t the only site having this issue if that helps.


And you are on Windows 10?


Yes I am on Windows 10.


I also have these issues, with a fairly good computer (GTX 1080, i7 4790k OC’d to 5GHz). I first only noticed this issue on my 1440p 144Hz monitor, but now its super laggy on my 1080p monitor as well; only in fullscreen. Videos work fine on YouTube. Also on a new-ish version of Chrome, on Windows 10.


Thanks a lot for providing these details. I’m still having problems to reproduce the issue but I will do some further investigation next week.

BTW: Do you experience the same problem with a video from Vimeo?


I have the same problem still looking for answers :slight_smile:


Thanks for reporting this. Im still a bit in the dark regarding this one since all my tests worked fine so far. Does the problem also occur when you play a video from “Vidme”?


No, everythink works fine on vidme and youtube. The video drops to 5 fps when i put it in fullscreen on watch2gether.


Thank you… and when you watch a Vidme video on Watch2Gether you have the same problem? Or does it only affect Youtube videos on Watch2Gether?


Right well, considering this still gets a lot of views and nobody is talking, what’s the deal with the fullscreen mode? Every video I watch on here lags when I got to fullscreen, the fps drop is insane. Whereas when I view them in their source link the lag is gone. Help?



Can you post a link to a video where this happens and tell me which browser / version on which operating system you are using? I will then try to reproduce this issue.



For example

Google Chrome - 62.0.3202

Windows 10 - Professional 64-bit


I realize this is kinda a half dead thread, but I’m having this issue. I’ve had this problem pop up a few times in the past then go away, and then return. This time it’s returned after I restarted my computer the other day…

Win 7, Google Chrome…
Video stuttering only ever happens in fullscreened versions of W2G for me. Not YTube, nothing. Are there any responses from mods/devs?