Problems I have post UI change

#1

This has been happening ever since the new UI change. Don’t get me wrong, I don’t personally care what the UI looks like or whether you guys make a Plus service but functionality needs to be key. Theres a few bugs ive run into personally that I want to address and see if any of them can be fixed or at least known about.

Autoplay:
Ever since the new UI this weird bug happens where if I or someone else tabs out of Watch together after the video ends, as soon as they tab back in it autoplays. This is annoying because anyone who isn’t tabbed in because they are say searching for a video to post has to tab into watch together and pause it. I don’t know what is causing it, and I don’t know all that much when it comes to software. However, a shot in the dark tells me that for some reason it triggers autoplay because the video returns to its unplayed state upon completion. In comparison to the old version where when a video ended, it showed that screen with anywhere from 3-10 recommend videos all in small boxes, this version just brings the video to the first frame or thumbnail with a play button over it. Maybe that has nothing to do with it maybe it does but this new bug gets really annoying with a lot of people constantly switching tabs.

Twitch Clips:
This website used to accept twitch clips, now if you try to post one it constantly loads forever despite used to saying in the search bar it accepts clips and vods. Its quite annoying because personally I watch a lot of twitch content especially with the boom of GTA RP and there’s loads of clips on twitch and not much besides compilations on youtube so if I want to post a funny clip, I have to open the full vod and select the time I want specifically to copy and hope because only 10% of the time does it actually skip ahead like its supposed to. If it doesn’t I have to manually scrub through to the right time and it just takes up time and is frustrating.

Twitch in general:
The twitch player still has its functions from twitch on the video. For instance fullscreen, volume control, and play pause. However, the problem occurs when the audio for twitch is for whatever reason muted, you cannot access the volume on twitch because as soon as you hover over the embedded video the Watch together bar covers it up. And since the only thing the watch together bar is synced with is play/pause and scrub control, the volume bar is irrelevant if embedded twitch volume is muted. I believe my solution was to have someone else play the link I posted, and then when I hovered over it I could access the twitch bar but I’m not certain.

All in all I really like the website, theres not much good competition out there, I just wish some of the old functionality was still working before adding a new flare to the website and holding new features behind a paywall.

For clarities sake I am running latest windows build and latest chrome build.

#2

Thanks a lot for you feedback

  • autoplay - i heard about this issue before but so far I was not able to reproduce it. It might be related to an Chrome update (v74). Browser vendors have recently introduced changes to the way autoplays are allowed or prevented and this might have an impact here. I’ll look into this again.

  • Twitch - Can you send me a link (here or PM) that used to be working and fails to play now? The overlay issue with the player menu should have actually been resolved a few days ago. Have a look.