Chrome Tab for Watch2Gether Crashing Today


Not sure what’s going on. I’m running Mac OS 10.12.13 with latest version of Chrome. Watch2Gether has been crashing all day. I checked my Activity Monitor and the process for that Chrome tab is taxing my CPU at 130%. Eventually Chrome kills it and I have to refresh. It works well for awhile but then eventually becomes a resource hog again. It has never done this before, not sure why it’s starting today. My buddy who I use it with has experienced it a little bit on his side too. Had to restart his computer to get it to load for him again.



Thanks a lot for your bug report. Which version of chrome are you using?


Sorry just saw that you wrote latest… Did you enable your webcam?


Version 56.0.2924.87 (64-bit)

Webcam is not enabled. I usually don’t have it on.


Thanks. Did you watch videos from Youtube or also from other platforms?


We just used it to watch YouTube today.


Ok. i’ll try to reproduce the issue. Does this problem also appear when you run Watch2Gether in a Chrome incognito window?


I’ll try icognito window too. See if it helps. It’s very inconsistent so it’s difficult to reproduce.


Thanks a lot. Would be great to know if you find a way to reproduce it.


Hey… do you still experience this issue?


Yeah, it’s still being weird today. Just really sluggish scrolling around and searching for things. Also I noticed that the Chrome tab for Watch2Gether keeps loading. The little ‘spinning loading’ symbol shows up occasionally even when I’m not using it or anything happening in the room.

Maybe that’s normal and I’m just noticing it now? Performance does seem better in incognito mode… Still a little sluggish, but not nearly as bad as without Icognito mode.


Thanks for the update. Do you haven any extension installed in your Chrome? Sometimes they can cause weird side effects…


Flashblock, AdBlock Plus, Sharepoint Fix, TamperMonkey, Add to Amazon Wishlist.


I see… you can try to disable them one by one to see if one of them is causing the issue. So far i have not been able reproduce the problem on my side.


I figured it out! In the URL bar I was getting two notifications from Chrome that was blocking plugins and “unsafe” scripts. Here’s the screenshots of it

I just asked it to load the unsafe scripts and then white-listed flash blocked plugins from from my Settings menu.


Thanks for the update. Did you get to see which scripts where blocked?


Ah I didn’t. Sorry :frowning: I should’ve looked.